Monkey Tree Hosting - Issues using Microsoft 365 services – Incident details

Issues using Microsoft 365 services

Resolved
Operational
Started almost 2 years agoLasted about 2 hours

Affected

Managed IT

Degraded performance from 9:37 AM to 9:38 AM, Operational from 9:38 AM to 12:00 PM

MTH 365

Degraded performance from 9:37 AM to 9:38 AM, Operational from 9:38 AM to 12:00 PM

Updates
  • Resolved
    UTC
    Resolved

    Microsft have determined through service telemetry that the Microsoft 365 service and environment was healthy. An external ISP networking issue may have resulted in access issues or latency. A service incident didn't actually occur and this communication will expire in 24 hours.

  • Identified
    UTC
    Identified

    Microsoft are reviewing service monitoring telemetry and networking logs to isolate the root cause.

  • Investigating
    UTC
    Investigating

    Users in the United Kingdom have reported issues using Microsoft 365 services.